登录  注册 退出
苏杭php自学网
记录个人学习过程中碰见的问题和感受
要温柔,也要有屠龙的勇气
本站有学习资源,可自由下载学习资料
  1. 首页 > 数据库教程 > Linux服务器运维

linux上安装composer,tp5,.1更新到6.0

作者:苏杭 日期:2021-02-25 13:31:28 点击数:

根据需要,要把5.1更新到6.0


根据文档,安装composer ,顺利安装,使用composer更新tp6的时候发现出现如下错误,

linux上安装composer,tp5,.1更新到6.0(图1)

原来提示版本过低,所以需要进行 composer 版本更新:

切换到中国源:composer config -g repo.packagist composer https://packagist.phpcomposer.com

更新到最新版: wget https://getcomposer.org/composer.phar


进行进行到tp6:

composer create-project topthink/think tp

发现如下错误:
linux上安装composer,tp5,.1更新到6.0(图2)

原来是pcntl_signal 函数被禁用了,将他解除,再继续操作:

发现又有错误, proc_open 这个函数也被禁用了,将他解除,再继续操作

linux上安装composer,tp5,.1更新到6.0(图3)


linux上安装composer,tp5,.1更新到6.0(图3)

可以看到,继续顺利更新了

linux上安装composer,tp5,.1更新到6.0(图5)

tp5.1 成功升级到6.0 !


随便看看
QQ在线咨询
电话:
182 7047 6708
交流微信:
su18270476708